Hi Scott,

I just retried with 3.1.17 and was able to reproduce the issue you reported.
I then tried the same with 3.1.18 and it worked there.
So it should be fixed with the 3.1.18 release.

Best regards
Jan

Am Donnerstag, 20. April 2017 09:12:32 UTC+2 schrieb Jan:
>
> Hi Scott,
>
> it will hopefully turn out to be a side-effect of issue #2422 (
> https://github.com/arangodb/arangodb/issues/2422 
> <https://www.google.com/url?q=https%3A%2F%2Fgithub.com%2Farangodb%2Farangodb%2Fissues%2F2422&sa=D&sntz=1&usg=AFQjCNGgZ3QGbRTwJDfxzdT0oOizlmeyow>)
>  
> which will be fixed in 3.1.18 (the next release).
> It would be very helpful if you could try that release when it comes out. 
> I expect it to be released this week.
> Best regards
> Jan
>
> Am Mittwoch, 19. April 2017 18:31:01 UTC+2 schrieb Scott B.:
>>
>> Jan,
>>
>> Thanks for the reply.  I have the issue on three different ArangoDB 
>> servers, all running on Ubuntu 16.04 LTS.
>>
>> If you don't see the issue, then I'm beginning to suspect it is caused by 
>> some weird edge case, perhaps in our data.  I've sent you a few attachments 
>> and a more detailed explanation that might help narrow down the issue.
>>
>> This isn't a critical issue for us (hash indexes work fine for now), just 
>> very strange.
>>
>> Scott
>>
>> On Tuesday, April 18, 2017 at 5:53:53 AM UTC-6, Jan wrote:
>>>
>>> Hi Scott,
>>>
>>> I just tried creating a persistent index via the web UI. The index was 
>>> on field "arrayName[*].propertyName" as suggested by you.
>>> The index was actually created and it seems to work for me. The type of 
>>> the index is also "persistent" when I look at the index in detail later.
>>> I am using 3.1.17 with the latest changes from the 3.1 branch that have 
>>> not been released yet.
>>> As it seems to work there, I suspect the issue you are seeing is caused 
>>> by the same issue as reported here: 
>>> https://github.com/arangodb/arangodb/issues/2422
>>> Note that this issue has been fixed in 3.1.18, which will be released 
>>> soon.
>>>
>>> Best regards
>>> Jan
>>>
>>> Am Donnerstag, 13. April 2017 23:36:29 UTC+2 schrieb Scott B.:
>>>>
>>>> Using the ArangoDB web UI, I used to be able to create persistent 
>>>> indexes on the properties of arrays by using: arrayName[*].propertyName
>>>>
>>>> However, now (in 3.1.17) that no longer appears to actually create a 
>>>> persistent index.  It has been a while since I've modified indexes, so I'm 
>>>> not sure which version I last used when it did work.  I am not marking 
>>>> them 
>>>> as unique or sparse.
>>>>
>>>> However, I can still use the same notation to create a hash 
>>>> (non-persistent) index.  Did something change with regard to persistent 
>>>> indexes I'm unaware of, or is this a bug?
>>>>
>>>

-- 
You received this message because you are subscribed to the Google Groups 
"ArangoDB" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to arangodb+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to