Date: Monday, January 23, 2017 @ 11:26:19
  Author: felixonmars
Revision: 287194

upgpkg: pyqt4 4.12-1

Modified:
  pyqt4/trunk/PKGBUILD

----------+
 PKGBUILD |   20 ++++++++++----------
 1 file changed, 10 insertions(+), 10 deletions(-)

Modified: PKGBUILD
===================================================================
--- PKGBUILD    2017-01-23 11:12:16 UTC (rev 287193)
+++ PKGBUILD    2017-01-23 11:26:19 UTC (rev 287194)
@@ -6,20 +6,20 @@
 
 pkgbase=pyqt4
 pkgname=('pyqt4-common' 'python-pyqt4' 'python2-pyqt4')
-pkgver=4.11.4
-pkgrel=5
+pkgver=4.12
+pkgrel=1
 arch=('i686' 'x86_64')
 url='http://www.riverbankcomputing.com/software/pyqt/intro'
 license=('GPL')
 makedepends=('python-sip' 'python-dbus' 'python2-sip' 'phonon-qt4' 'mesa'
              'python2-opengl' 'qt-assistant-compat' 'qtwebkit' 'python2-dbus')
-source=("http://downloads.sourceforge.net/pyqt/PyQt-x11-gpl-${pkgver}.tar.gz";)
-md5sums=('2fe8265b2ae2fc593241c2c84d09d481')
+source=("http://downloads.sourceforge.net/pyqt/PyQt4_gpl_x11-${pkgver}.tar.gz";)
+md5sums=('eb8c338f2d8842aa7655e8e1aa840bed')
 
 build() {
-  cp -a PyQt-x11-gpl-${pkgver} Py2Qt-x11-gpl-${pkgver}
+  cp -a PyQt4_gpl_x11-${pkgver}{,-py2}
 
-  cd PyQt-x11-gpl-${pkgver}
+  cd PyQt4_gpl_x11-${pkgver}
   python configure-ng.py \
     --confirm-license \
     --no-sip-files \
@@ -32,7 +32,7 @@
   make
 
   ### Python2 version ###
-  cd ../Py2Qt-x11-gpl-${pkgver}
+  cd ../PyQt4_gpl_x11-${pkgver}-py2
   python2 configure-ng.py \
     --confirm-license \
     --no-sip-files \
@@ -52,7 +52,7 @@
   conflicts=('pyqt-common')
   provides=("pyqt-common=${pkgver}")
 
-  cd PyQt-x11-gpl-${pkgver}
+  cd PyQt4_gpl_x11-${pkgver}
   make -C pyrcc INSTALL_ROOT="${pkgdir}" install
   make -C pylupdate INSTALL_ROOT="${pkgdir}" install
 
@@ -72,7 +72,7 @@
   conflicts=('pyqt')
   provides=("pyqt=${pkgver}")
 
-  cd PyQt-x11-gpl-${pkgver}
+  cd PyQt4_gpl_x11-${pkgver}
   # INSTALL_ROOT is needed for the QtDesigner module, the other Makefiles use 
DESTDIR
   make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
 
@@ -92,7 +92,7 @@
   conflicts=('python2-pyqt')
   provides=("python2-pyqt=${pkgver}")
 
-  cd Py2Qt-x11-gpl-${pkgver}
+  cd PyQt4_gpl_x11-${pkgver}-py2
   # INSTALL_ROOT is needed for the QtDesigner module, the other Makefiles use 
DESTDIR
   make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
 

Reply via email to