On 5/27/2023 3:37 PM, Steve Matzura wrote:
On 5/27/2023 11:40 AM, aster...@phreaknet.org wrote:

Relative paths are relative to your language-specific directory.

Ya know, that's the one thing I didn't do was test Playback before copying the sound files out of /usr/share/asterisk/sounds/en_us into /var/lib/asterisk/sounds--I don't even know for sure that hello-world was playing from the /var path and not the /usr path. Good idea to test that and see what's really going on. I think I set too much store by these books sometimes. But when that's all I have, I tend to go with what I know, and if the book is all I know ... well ...

A great reason to avoid Asterisk packages and compile from source instead. You'll save yourself a lot of headaches.

That's how I started, by trying to build version 18 from source. It failed. Colossally. The compile of sources would run for a while, then the machine would crash spectacularly--I mean, not just hang or reboot. It actually turned itself off. I tried it several times, and each time it failed in the same way, but at a different spot in the compile process. If ever I could figure out a way to trace that one down, I would. It was the strangest thing.

This sounds like your machine is defective in some major way. Granted, compiling software is pretty intensive, but your machine shouldn't just crash. I would try to figure that out. Is this a VM / bare metal? Have you tried this on another machine?

-- Bandwidth and Colocation Provided by http://www.api-digital.com --

Check out the new Asterisk community forum at: https://community.asterisk.org/

New to Asterisk? Start here:

asterisk-users mailing list
To UNSUBSCRIBE or update options visit:

Reply via email to