is there a way to name operations in a way it is less confusing and so do away with MEP based names. (e.g. SendRecive Operation .. ReciveSendOperation ) We explained every body saying since MEP is relative to the service provider .. we called request-response InOut based on the argument.
Now if we start look at the things in the service requester's point of view (while still using MEP names) .. it will be confusing. I have mixed feeling on this .. Thanks very much Srinath On 3/3/06, Sanjiva Weerawarana <[EMAIL PROTECTED]> wrote: > On Sat, 2006-03-04 at 05:21 +0600, Sanjiva Weerawarana wrote: > > > client side normal In-Out is called Out-In? (Which is against notions > > > of WSDL2.0 AFAIK) > > > > No .. > > Sorry; my answer above could be confusing: The answer to your question > above is "yes" .. what I said "no" for was your assertion that its > against WSDL! WSDL (esp. 2.0) is very clear that its a description of > the service from the service provider's point of view .. in means the > message is going into the service provider and out of the service > client. There's no confusion in WSDL at all; all we're doing is using > the WSDL MEP concept on the client side and following exactly the same > pattern. > > Sanjiva. > > -- ============================ Srinath Perera: http://www.cs.indiana.edu/~hperera/ http://www.bloglines.com/blog/hemapani
