On Fri, 2006-03-03 at 20:16 -0500, Srinath Perera wrote: > is there a way to name operations in a way it is less confusing and so > do away with MEP based names. (e.g. SendRecive Operation .. > ReciveSendOperation ) We explained every body saying since MEP is > relative to the service provider .. we called request-response InOut > based on the argument.
I think the names we have are fine- the names come from the message exchange pattern: so a client using an In-Out operation of a service executes an Out-In message exchange pattern. That is correct and accurate both w.r.t. the actual messages flowing and the WSDL. > Now if we start look at the things in the service requester's point of > view (while still using MEP names) .. it will be confusing. I have > mixed feeling on this .. I don't think its confusing: we're not mixing anything .. we're *always* looking at the underlying message exchange. WSDL is a description of that message exchange at the service from the point of view of the service. In our case, we're not generating WSDLs for the client (but we could if necessary) and it'd have reversed operations .. which again is the correct behavior. Sanjiva.
