Actually, let me put this another way ... On Wed, Jul 03, 2002 at 05:49:43AM -0400, Sam Ruby wrote: > I just want to note that at some point, many developer don't want to > think in terms of HTTP or SOAP, but rather in terms like > getQuantityInStock(PartNumber="123").
Are you sure it's that and not this; getQuantityInStockForPartNumber123() ? or getQuantity( type="InStock", PartNumber="123" ) ? I mean, where do you draw the line? That first suggestion of mine is obviously silly, because it's not parameterized at all; it does one thing and one thing only. But the second is more reusable than your suggestion, because I can use it for retrieving many types of quantities ("InStock", "OnOrder", etc..). So why don't we generalize it just a little bit further to; get( http://example.org/quantity-in-stock?partnumber=123 ) ? And that, in a nutshell, is REST. MB -- Mark Baker, CTO, Idokorro Mobile (formerly Planetfred) Ottawa, Ontario, CANADA. [EMAIL PROTECTED] http://www.markbaker.ca http://www.idokorro.com