On Sat, Oct 29, 2016 at 5:43 PM, Christopher Hansen <hanse...@gmail.com> wrote:
> OK, I found my problem and I fixed it.  I had a "bad PPA" I needed to remove 
> in order for the update_kernal.sh script to complete properly.  Here's what I 
> get from the example code:
>
> This example computes y[i] = M[i] * x[i] + C on single precision floating 
> point arrays of size 2097152
> - Computation on the ARM is parallelized across the A15s using OpenMP.
> - Computation on the DSP is performed by dispatching an OpenCL NDRange kernel 
> across the compute units (C66x cores) in the compute device.
>
> Running.....
>
> Average across 5 runs:
> ARM (2 OpenMP threads)         : 0.007877 secs
> DSP (OpenCL NDRange kernel)    : 0.007614 secs
> OpenCL-DSP speedup             : 1.034475
>
>
> Is that the expected result?

Yeah, i was getting around 1.1x on v4.4.x

When i last tried ti's sdk (v4.4.x based on the Alpha -X15 (no support
for the rev b yet)) i was getting around 0.7/0.8 "speedup"...

Back in v4.1.x (about a year ago, with the alpha-x15) i thought it was
around 3x/4x speedup

So there's definitely a speed regression, (maybe we are in a slow
clock state for the dsp?)

But it atleast it's working again... ;)

Regards,

-- 
Robert Nelson
https://rcn-ee.com/

-- 
For more options, visit http://beagleboard.org/discuss
--- 
You received this message because you are subscribed to the Google Groups 
"BeagleBoard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to beagleboard+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/beagleboard/CAOCHtYgddimrvwV-CDEtz3shgpCo8ioSbCGVYygddG1SLb7DSA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to