Hi,

I burned a uSD card with 
bbx15-debian-8.10-console-armhf-2018-01-01-1gb.img.xz which I got from 
elinux.org.  The kernel which comes with that image is 4.4.91-ti-r141.  But 
I have been building kernel version 4.4.110-ti-r142  from source following 
the instructions on eewiki.net for the BB-X15, and copying the kernel 
image, dtbs, and modules to that same uSD card which still has the stock 
kernel on it. Both kernel's appear to run just fine from uSD card when 
uname-r is changed in uEnv.txt.  

But when I run try to run the eMMC flasher script with the 4.4.110 (built 
from source) kernel running instead of the "stock kernel" running the 
flasher script dies when /proc/sys/vm/min_free_kbytes isn't there and then 
you see a  kernel panic (please see console dump below).  However, when I 
switch the running kernel back to the stock kernel, 4.4.91-ti-r141 which 
came with that image, the eMMC flasher script again works.  I've tried 
running both, /opt/scripts/tools/eMMC/init-eMMC-flasher-v3-no-eeprom.sh 
and init-eMMC-flasher-v3-x15_b1.sh, both with the same result (I think).

I'm wondering what other crucial step needs to be followed which I 
missed... I didn't touch the filesystem which was already part of the 
2018-01-01 console BB-X15 image on that uSD card, but when I run "mount" on 
both kernels, I get differences (see below).


Please take a look at what I've posted below and give me some clues as to 
where to look or what to read up on next..

Thanks!!




*When the kernel built from source (4.4.110) is running from uSD card, and 
I'm logged in as debian (or have typed sudo su from debian), I'm able to 
run /sbin/sysctl -n vm.min_free_kbytes both as "debian" and su.  So proc 
appears to be present on the 4.4.110 kernel running from uSD card once 
logged in:

*When running both kernels from the uSD card, I ran "zcat /proc/config.gz" 
and the configurations were "pretty similar." (see diff below):

< # Linux/arm 4.4.91 Kernel Configuration
---
> # Linux/arm 4.4.110 Kernel Configuration
1208a1209
> # CONFIG_NET_DSA is not set
2809,2810c2810,2811
< CONFIG_SERIAL_8250_NR_UARTS=6
< CONFIG_SERIAL_8250_RUNTIME_UARTS=6
---
> CONFIG_SERIAL_8250_NR_UARTS=9
> CONFIG_SERIAL_8250_RUNTIME_UARTS=9


*One thing that's different is the outputs of the "mount" command run on 
the two kernels: 

> /dev/mmcblk0p1 on / type ext4 (rw,relatime,errors=remount-ro,data=ordered)
> devtmpfs on /dev type devtmpfs 
(rw,relatime,size=824360k,nr_inodes=97302,mode=755)
3,6d4
< udev on /dev type devtmpfs 
(rw,relatime,size=10240k,nr_inodes=96053,mode=755)
< devpts on /dev/pts type devpts 
(rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
< tmpfs on /run type tmpfs (rw,nosuid,relatime,size=372500k,mode=755)
< /dev/mmcblk0p1 on / type ext4 (rw,relatime,errors=remount-ro,data=ordered)
8a7,8
> devpts on /dev/pts type devpts 
(rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
> tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)
13,17d12
< cgroup on /sys/fs/cgroup/freezer type cgroup 
(rw,nosuid,nodev,noexec,relatime,freezer)
< cgroup on /sys/fs/cgroup/blkio type cgroup 
(rw,nosuid,nodev,noexec,relatime,blkio)
< cgroup on /sys/fs/cgroup/perf_event type cgroup 
(rw,nosuid,nodev,noexec,relatime,perf_event)
< cgroup on /sys/fs/cgroup/devices type cgroup 
(rw,nosuid,nodev,noexec,relatime,devices)
< cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup 
(rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
19c14,15
< cgroup on /sys/fs/cgroup/cpuset type cgroup 
(rw,nosuid,nodev,noexec,relatime,cpuset)
---
> cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup 
(rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
> cgroup on /sys/fs/cgroup/perf_event type cgroup 
(rw,nosuid,nodev,noexec,relatime,perf_event)
21c17,20
< systemd-1 on /proc/sys/fs/binfmt_misc type autofs 
(rw,relatime,fd=22,pgrp=1,timeout=0,minproto=5,maxproto=5,direct)
---
> cgroup on /sys/fs/cgroup/cpuset type cgroup 
(rw,nosuid,nodev,noexec,relatime,cpuset)
> cgroup on /sys/fs/cgroup/freezer type cgroup 
(rw,nosuid,nodev,noexec,relatime,freezer)
> cgroup on /sys/fs/cgroup/devices type cgroup 
(rw,nosuid,nodev,noexec,relatime,devices)
> cgroup on /sys/fs/cgroup/blkio type cgroup 
(rw,nosuid,nodev,noexec,relatime,blkio)
24c23
< configfs on /sys/kernel/config type configfs (rw,relatime)
---
> systemd-1 on /proc/sys/fs/binfmt_misc type autofs 
(rw,relatime,fd=33,pgrp=1,timeout=0,minproto=5,maxproto=5,direct)
26c25,26
< tmpfs on /run/user/1000 type tmpfs 
(rw,nosuid,nodev,relatime,size=186252k,mode=700,uid=1000,gid=1000)
---
> configfs on /sys/kernel/config type configfs (rw,relatime)
> tmpfs on /run/user/1000 type tmpfs 
(rw,nosuid,nodev,relatime,size=186248k,mode=700,uid=1000,gid=1000)




**** Console dump when attempting to flash the eMMC using kernel 
4.4.110-ti-r142 compiled from source *****

================================================================================
Starting eMMC Flasher from microSD media
Version: [1.20171220: btrfs...]
================================================================================

================================================================================
Prepare environment for flashing
Starting at Mon Jan  1 00:28:24 UTC 2001
----------------------------------------
==> Giving system time to stablize...
5 4 3 2 1 
==> Preparing /tmp
==> Preparing sysctl
sysctl: cannot stat /proc/sys/vm/min_free_kbytes: No such file or directory
Traceback (last called is first):
     prepare_environment() in /opt/scripts/tools/eMMC/functions.sh:148
     main() in /opt/scripts/tools/eMMC/init-eMMC-flasher-v3-x15_b1.sh:43
The command value_min_free_kbytes=$(sysctl -n vm.min_free_kbytes) exited 
with exit code 255.
================================================================================
Tearing Down script environment
==> Unmounting /tmp

Usage:
 blockdev -V
 blockdev --report [devices]
 blockdev [-v|-q] commands devices

Available commands:
 --getsz                   get size in 512-byte sectors
 --setro                   set read-only
 --setrw                   set read-write
 --getro                   get read-only
 --getdiscardzeroes        get discard zeroes support status
 --getss                   get logical block (sector) size
 --getpbsz                 get physical block (sector) size
 --getiomin                get minimum I/O size
 --getioopt                get optimal I/O size
 --getalignoff             get alignment offset in bytes
 --getmaxsect              get max sectors per request
 --getbsz                  get blocksize
 --setbsz <bytes>          set blocksize on file descriptor opening the 
block device
 --getsize                 get 32-bit sector count (deprecated, use --getsz)
 --getsize64               get size in bytes
 --setra <sectors>         set readahead
 --getra                   get readahead
 --setfra <sectors>        set filesystem readahead
 --getfra                  get filesystem readahead
 --flushbufs               flush buffers
 --rereadpt                reread partition table

!==> We don't know how to reset the leds as we are not a BBB compatible 
device
[    9.441093] Kernel panic - not syncing: Attempted to kill init! 
exitcode=0x00000100
[    9.441093] 
[    9.450268] CPU: 1 PID: 1 Comm: init-eMMC-flash Not tainted 
4.4.110-ti-r142 #10
[    9.457603] Hardware name: Generic DRA74X (Flattened Device Tree)
[    9.463733] [<c001be78>] (unwind_backtrace) from [<c0015a90>] 
(show_stack+0x20/0x24)
[    9.471510] [<c0015a90>] (show_stack) from [<c05c58e0>] 
(dump_stack+0x8c/0xa0)
[    9.478765] [<c05c58e0>] (dump_stack) from [<c0162170>] 
(panic+0x100/0x288)
[    9.485758] [<c0162170>] (panic) from [<c0048774>] 
(complete_and_exit+0x0/0x2c)
[    9.493097] [<c0048774>] (complete_and_exit) from [<c0048810>] 
(do_group_exit+0x50/0xe0)
[    9.501221] [<c0048810>] (do_group_exit) from [<c00488c0>] 
(__wake_up_parent+0x0/0x30)
[    9.509171] [<c00488c0>] (__wake_up_parent) from [<c0010e20>] 
(ret_fast_syscall+0x0/0x50)
[    9.517381] CPU0: stopping
[    9.520099] CPU: 0 PID: 0 Comm: swapper/0 Not tainted 4.4.110-ti-r142 #10
[    9.526910] Hardware name: Generic DRA74X (Flattened Device Tree)
[    9.533032] [<c001be78>] (unwind_backtrace) from [<c0015a90>] 
(show_stack+0x20/0x24)
[    9.540808] [<c0015a90>] (show_stack) from [<c05c58e0>] 
(dump_stack+0x8c/0xa0)
[    9.548060] [<c05c58e0>] (dump_stack) from [<c001952c>] 
(handle_IPI+0x2ac/0x2cc)
[    9.555486] [<c001952c>] (handle_IPI) from [<c00095f4>] 
(gic_handle_irq+0x98/0x9c)
[    9.563090] [<c00095f4>] (gic_handle_irq) from [<c0ab2814>] 
(__irq_svc+0x54/0x70)
[    9.570598] Exception stack(0xc1013ef8 to 0xc1013f40)
[    9.575665] 3ee0:                                                      
 00000001 00000000
[    9.583875] 3f00: fe600000 00000000 c1012000 c1015b44 00000000 c10ea5a8 
c0aba57c c0d4cb38
[    9.592083] 3f20: 00000000 c1013f54 c1013f34 c1013f48 c0033280 c00119c0 
600f0013 ffffffff
[    9.600296] [<c0ab2814>] (__irq_svc) from [<c00119c0>] 
(arch_cpu_idle+0x30/0x4c)
[    9.607724] [<c00119c0>] (arch_cpu_idle) from [<c008e0f8>] 
(default_idle_call+0x30/0x3c)
[    9.615847] [<c008e0f8>] (default_idle_call) from [<c008e460>] 
(cpu_startup_entry+0x300/0)
[    9.624493] [<c008e460>] (cpu_startup_entry) from [<c0aacc94>] 
(rest_init+0x88/0x8c)
[    9.632271] [<c0aacc94>] (rest_init) from [<c0f54df4>] 
(start_kernel+0x434/0x454)
[    9.639787] ---[ end Kernel panic - not syncing: Attempted to kill init! 
exitcode=0x000000
[    9.639787] 


-- 
For more options, visit http://beagleboard.org/discuss
--- 
You received this message because you are subscribed to the Google Groups 
"BeagleBoard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to beagleboard+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/beagleboard/5f47f4b8-3e74-4c70-9c9c-b044ab21c688%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to