I do hardware. Software was something i did in the 80s z80 asm code and
c coding on a univac ( yeah i know )

If i run your command as root in my current directory

root@beaglebone:/home/debian# make src/arm/BB-I2C1-00A0.dtb
make: *** No rule to make target 'src/arm/BB-I2C1-00A0.dtb'.  Stop.


Been using linux since the 90s

2 years ago i could just invoke the dts compiler

dtc -O dtb -o BB-I2C1-00A0.dtb -b 0 BB-I2C1-00A0.dts

in whatever directory i was in normally someplace safe where i can play
without fear of destroying something important

now things have changed and its tough to see whats changed
all examples everywhere also say i can invoke the compiler in a temp
directory.

thanks Robert for your assistance.

On 2/14/2018 7:36 AM, Robert Nelson wrote:
> On Wed, Feb 14, 2018 at 8:15 AM, evilwulfie <evilwul...@gmail.com> wrote:
>> So i need to create a dtb file for some custom hardware.
>> I made one 2 years ago that compiled correctly
>> on the latest IOT image it does not compile.
>> So i figure, hey maybe something has changed
>> so i pull the /opt/source/bb.org-overlays/src/arm/BB-I2C1-00A0.dts file
>> to a temp directory and try to compile it
>> Funny i get the same error and i get no compile.
>>
>> Error: BB-I2C1-00A0.dts:13.1-9 syntax error
>> FATAL ERROR: Unable to parse input tree
>>
>>
>> just wondering whats changed.
>>
>> apt says i am at the latest dts compiler
>>
>> anybody try to compile anything recently ?
> make src/arm/BB-I2C1-00A0.dtb
>
> Regards,
>

-- 
For more options, visit http://beagleboard.org/discuss
--- 
You received this message because you are subscribed to the Google Groups 
"BeagleBoard" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to beagleboard+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/beagleboard/37566677-81f1-7581-fecc-35d8dc0768b7%40gmail.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to