Hi,

It may be time to deprecate the seq*apply family of functions, including
seqapply, mseqapply, tseqapply, seqby and seqsplit. These are ancient
functions named in referece to the "Sequence" class, now called "Vector".
It would seem better for the user to write: asList(lapply(...)) instead of
coming up with an alias for that. For readability, we should probably
export asList() as an alias for as(x, "List"), which I just cleaned up.

There is one caveat though: mseqapply has been particularly useful, because
it delegates to mapply_List, which is smart enough to handle any vector
argument in "...". The mapply,List method of course restricts everything to
List. We should probably export mapply_List, probably with a better name.
Suggestions?

Michael

        [[alternative HTML version deleted]]

_______________________________________________
Bioc-devel@r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/bioc-devel

Reply via email to