On Tue, 3 Jan 2006, Akim Demaille wrote: > >>> "Joel" == Joel E Denny <[EMAIL PROTECTED]> writes: > > > On Mon, 2 Jan 2006, Akim Demaille wrote: > >> Installed. > > > Thanks. > > >> For some reason, glr.c sometimes uses yydefact[], and at others > >> yydefaultAction. > > > I don't know why. I'd prefer it to be consistent. Even though I'd > > normally vote for the function, yydefact is more consistent with yacc.c. > > Right, but the glr skeleton is much more readable, and I won't prefer > the converse :)
I can't argue with that. > The glr skeleton tries to keep some abstraction over > how the automaton is encoded. Its yygetLRActions for instance is > something that would clarify yacc.c. So, since we're looking at it, maybe yacc.c should have a yydefaultAction? One small step for abstraction. Joel
