#7787: GCC-6 causes compilation problems with Qt4 and its corresponding Qtwebkit
--------------------+-----------------------
 Reporter:  renodr  |       Owner:  renodr
     Type:  defect  |      Status:  assigned
 Priority:  normal  |   Milestone:  7.10
Component:  BOOK    |     Version:  SVN
 Severity:  normal  |  Resolution:
 Keywords:          |
--------------------+-----------------------

Comment (by renodr):

 Here is my list of packages to be tested:


 {{{
 Graphviz (Needs patch)
 Highlight (systemd)
 PIN-Entry (Use Qt5 instead of Qt4)
 CMake (Use Qt5 instead of Qt4)
 Doxygen (Use Qt5 instead of Qt4)
 WPA_supplicant (Qt5 supported? Porting might be needed)
 Avahi (Qt5 supported? Porting might be needed)
 NetworkManager (Qt5 supported? Porting might be needed)
 Wireshark (Use Qt5 instead of Qt4)
 Transmission (Use Qt5 instead of Qt4)
 v4l-utils (Use Qt5 instead of Qt4)
 Audacious (Use Qt5 instead of Qt4)
 VLC (Use Qt5 instead of Qt4 - Problems?)
 }}}

 In addition, I found that the following changes are needed for gst-
 plugins-* (Dependencies):

 {{{
 gst-plugins-base: Replace Qt4 with Qt5, Used in examples
 gst-plugins-good: Qt is no longer a dependency... verified from configure
 gst-plugins-bad: Add Qt5 as a dependency - Used for examples (Basic
 Player) based upon the GstPlayer API (added in 1.8.0)
 }}}

--
Ticket URL: <http://wiki.linuxfromscratch.org/blfs/ticket/7787#comment:3>
BLFS Trac <http://wiki.linuxfromscratch.org/blfs>
Beyond Linux From Scratch
-- 
http://lists.linuxfromscratch.org/listinfo/blfs-book
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Reply via email to