On Wed, Oct 31, 2012 at 03:54:20PM -0700, Fernando de Oliveira wrote:
> I do not remember getting this before "lfs7.2":
> configure: error: Package requirements (fuse >= 2.3 glib-2.0 gthread-2.0) 
> were not met:
> No package 'glib-2.0' found
> No package 'gthread-2.0' found
> I am trying to build in chroot.
> []s,
> Fernando

 I think there was *perhaps* a short period where LFS included
pkg-config with a dependency of glib-2.0, but it wasn't a very long
period.  Old versions of pkg-config shipped an internal glib1, and
the current version ships an internal glib2.

 I guess that either sshfs-fuse has added dependencies, or else you
are building in a different order ?  I'm afraid I don't have any
interest in this package, but you need to be aware that dependencies,
and therefore the best build order for you, change with new releases
of packages.

  FWIW, it appears that a desktop machine can nowadays build most
packages while still in chroot (I haven't tried all of the
audio-video packages, nor the parts of gnome that I build) - in the
distant past, I believe things were very different.  On my *server*
I had a problem with postgresql (couldn't run the tests, because the
existing postgresql owned the socket), but again most packages can
be built in chroot.

das eine Mal als Tragödie, das andere Mal als Farce
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Reply via email to