On 1/15/20 4:09 PM, Alan Feuerbacher via blfs-support wrote:

On 1/15/2020 1:43 PM, Pierre Labastie via blfs-support wrote:
Le 15/01/2020 à 21:27, Alan Feuerbacher via blfs-support a écrit :
I just built the updated git-2.25.0 and ran the tests. The BLFS book says that running them as a normal user should produce no failures, but I immediately
get this error:

cat: version: Permission denied

/bin/sh: GIT-BUILD-OPTIONS+: Permission denied

But if I run the tests as root, all tests pass.

I don't know if this is a problem.

Hmmm, Maybe you can try to figure out this one by yourself: first check who is the owner of a "version" file, or GIT-BUILD-OPTIONS file (or file whose name begin with version or GIT-BUILD-OPTIONS), explore your build tree, checking for anything that could prevent a normal user to access the files, etc...

Pierre

In the build tree, there's a file "version" with owner "110493 5000" and permissions "-rw-r----". This is the same owner as "configure". These are the only files not owned by "root root". If as user lfs I "cat version" I get the same error as above -- as expected, given the permissions for "other". If I cat some random file with owner "root root" and permissions "-rw-rw-r-", it works fine, as expected. If, as root, I "cat version" I get the expected "2.25.0". I don't know what to make of this.

What does owner "110493 5000" mean? Why would only two files have this odd ownership and why is there no read permission for "other"?

For GIT-BUILD-OPTIONS the owner is "root root" with permissions "-rw-r--r--". I would guess that, since bash is given this file to execute, and there is no "x" in the permissions, we get the "permission denied" error. But if this is part of the testing, why does whatever software that makes the build tree not add "x" to the permissions?

And of course, since the BLFS book specifically indicates that running the tests as a normal user is the way to go, why are the ownership and permissions of these files not such that a normal user can run the tests?

Alan

When developing the instructions, we assume that you're building as a normal user, and not as the root user. This is to follow the philosophy of UNIX Administration of only using your superpowers when necessary (see http://linuxfromscratch.org/blfs/view/systemd/introduction/notes-on-building.html ). Seeing as you were able to get the tests to run as root though, you should be okay. We probably have that in there from a previous release where running the tests as root caused sporadic failures.

--
http://lists.linuxfromscratch.org/listinfo/blfs-support
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Reply via email to