Hi all,

How would you call an 'apply' counterpart that takes a metafunction class
and a _sequence_ of arguments, i.e.:

    typedef list_c<int,5,0> args;
    typedef apply_tuple< plus<>, args >::type sum; // this one
    BOOST_STATIC_ASSERT(sum::value == 5);

?

If it was run-time C++, I would be happy with 'apply_tuple', but in MPL
domain "tuple" isn't really the right word, and I don't like 'apply_seq' or,
worse yet, 'apply_sequence'. Or should it be 'seq_apply' (from an English
language standpoint)? 

Anyway, suggestions and opinions are welcome!

Aleksey
_______________________________________________
Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost

Reply via email to