Thanks Adrien. I was thinking about that. However, I understand some of them 
are not SATA - the manufacturers put their own simplified (and cheaper) 
controller in the the case, so it is not clear how it could be connected to a 

I could open the case to see, but that would void the warranty, and the owner 
may want to make a claim to get it replaced. Although maybe a replacement would 
be just as bad....



On 25/8/2023 18:52, Adrien Cordonnier wrote:
Hello David,
The disk is probably dead as suggested by the clicking sound.
If you really want to recover important data which are only on this disk, I 
suggest that you open the USB enclosure and connect the disk directly to the 
computer. The USB controllers are usually not the best to handle defective 

Le ven. 25 août 2023 à 10:56, David Morrison <> a 
écrit :

    A friend bought a WD Elements 2TB external portable disk, ie, USB powered. 
It worked ok for a day or two, then she could not get some files off it. She 
asked me to help.

    When I first plugged it in, it would mount. However, trying to copy files 
off it would start, and sometimes copy some files. Often, though, it would 
start copying then there would be a click from the drive, and it would just sit 
there, no error message, but not copying either. The disk was still spinning, 
as the vibration could be felt.

    So I started copying it using ddrescue to see if it could be recovered.

    bash-3.2# date ; ddrescue -n -f -s 2001GiB /dev/rdisk1 /dev/rdisk2 
Jenni.log ; date

    After nearly two days, it is reporting this:

    Press Ctrl-C to interrupt
          ipos:    4938 MB, non-trimmed: 4939 MB,  current rate:       0 B/s
          opos:    4938 MB, non-scraped:        0 B,  average rate:       0 B/s
    non-tried:    1995 GB, bad-sector:        0 B,    error rate:   32768 B/s
       rescued:        0 B,   bad areas:        0,        run time:  1d 17h 59m
    pct rescued:    0.00%, read errors: 75369,  remaining time:         n/a
                                   time since last successful read:         n/a
    Copying non-tried blocks... Pass 5 (forwards)

    The fact that it is on pass 5 and has still not rescued anything at all 
makes me think that the fault is not on the disk surface, but somewhere in the 
electronics. If so, then I suspect I am unlikely to get anything off it.

    The way it is going, it looks like it will take several weeks to finish. If 
this is going to be fruitless, I might as well stop now.

    Does this analysis sound reasonable? Is there any chance of recovering 

    This is ddrescue 1.23.



Reply via email to