I am Russian, so my English may be not perfect enough.

   My suggestions:

   1) The first thing to do with WD is to unmount the electronic board
   from the hermetic block, than clean the contact pads on the board,
   assemble back. See some videos on YouTube of how to do this.

   2) The second thing is useful for all USB-powered drives: try to
   connect the drive to power adapter (5V only!) without "Quick Charge"
   (that gives 9V!) and listen to the sounds it emits with just power,
   without data exchange, mounting etc.

   3) If everything is OK, then try connecting it to the computer and see

   4) Even if that did not help, there is a chance to attach SATA and
   power jacks and try to communicate with the drive in that way.
   Personally I never did so, but my comrades did that successfully. One
   such drive had one bad head - so we were able to recover about 55% of
   the information from it.

   25.08.2023, 10:57, "David Morrison" <davidmorrisonl...@gmail.com>:

     A friend bought a WD Elements 2TB external portable disk, ie, USB
     powered. It worked ok for a day or two, then she could not get some
     files off it. She asked me to help.
     When I first plugged it in, it would mount. However, trying to copy
     files off it would start, and sometimes copy some files. Often,
     though, it would start copying then there would be a click from the
     drive, and it would just sit there, no error message, but not
     copying either. The disk was still spinning, as the vibration could
     be felt.
     So I started copying it using ddrescue to see if it could be
     bash-3.2# date ; ddrescue -n -f -s 2001GiB /dev/rdisk1 /dev/rdisk2
     Jenni.log ; date
     After nearly two days, it is reporting this:
     Press Ctrl-C to interrupt
           ipos:    4938 MB, non-trimmed: 4939 MB,  current rate:       0
           opos:    4938 MB, non-scraped:        0 B,  average
     rate:       0 B/s
     non-tried:    1995 GB, bad-sector:        0 B,    error rate:
     32768 B/s
        rescued:        0 B,   bad areas:        0,        run time:  1d
     17h 59m
     pct rescued:    0.00%, read errors: 75369,  remaining time:
                                    time since last successful
     read:         n/a
     Copying non-tried blocks... Pass 5 (forwards)
     The fact that it is on pass 5 and has still not rescued anything at
     all makes me think that the fault is not on the disk surface, but
     somewhere in the electronics. If so, then I suspect I am unlikely to
     get anything off it.
     The way it is going, it looks like it will take several weeks to
     finish. If this is going to be fruitless, I might as well stop now.
     Does this analysis sound reasonable? Is there any chance of
     recovering anything?
     This is ddrescue 1.23.

Reply via email to