On 1/26/25 9:29 PM, James Youngman wrote:
error (0, 0,
   _("File system loop detected; "
     "the following directory is part of the cycle: %s"),
   safely_quote_err_filename (0, ent->fts_path));

Would it be clearer to stick to just saying "cycle" or "loop" but not using
both words?   I'm just considering that we may be making it harder to
understand the error message. It also might make it unobvious to
translators (who might wonder whether using different words was part of an
important distinction).

hmm, clarity is a good point - looking over the fence to GNU coreutils:
the message there is even more drastic:

https://git.savannah.gnu.org/cgit/coreutils.git/tree/src/system.h?h=v9.6#n728

  #define emit_cycle_warning(file_name) \
    do                                  \
      {                                 \
        error (0, 0, _("\
  WARNING: Circular directory structure.\n\
  This almost certainly means that you have a corrupted file system.\n\
  NOTIFY YOUR SYSTEM MANAGER.\n\
  The following directory is part of the cycle:\n  %s\n"), \
               quotef (file_name));     \
      }                                 \
    while (0)

Have a nice day,
Berny

Reply via email to