guix --version returns "guix (GNU Guix) 20161013.22". My config.scm
included (firmware (cons openfwwf-firmware %base-firmware)). I was using a
patch provided by bavier from irc to provide openfwwf-firmware (here is the
patch I created
/root/guix-modules/gnu/packages/firmware.scm, which was the patched
version. When I tried running "guix system reconfigure
--load-path=/root/guix-modules /etc/config.scm" it said that it could not
find openfwwf-firmware. I then ran "export
GUIX_PACKAGE_PATH=/root/guix-modules" and then ran "guix system reconfigure
/etc/config.scm" and it successfully found openfwwf-firmware and
reconfigured the system. That's why I think --load-path is not being

I'm guessing that to reproduce, I should boot to the system configuration I
had at the time and try the same thing. So I tried rebooting to the system
I had at that time, but it seems to have failed to successfully boot...
screen is stuck black right now, will try some more later. Just wanted to
provide more details in the meantime.

On Sun, Oct 16, 2016 at 2:24 PM, Ludovic Courtès <> wrote:

> Hello,
> Blah Blahh <> skribis:
> > Worked fine when I set GUIX_PACKAGE_PATH, did not when I tried using -
> > -load-path to pass the exact same directory. According to mark_weaver
> > from #guix it should, so here I am to mention it. Specifically I used
> > "guix system reconfigure --load-path=/root/guix-modules
> > /etc/config.scm" and it did not search in that directory, then I set
> > GUIX_PACKAGE_PATH to /root/guix-modules and ran the command without
> > the --load-path part and it found the package defined in a module in a
> > subdirectory of it.
> I just tried and it Works for Me with current master.
> What does ‘guix --version’ return?  What makes you think ‘--load-path’
> is not honored, perhaps because you’re using ‘specification->package’ in
> config.scm?
> Thanks,
> Ludo’.

Reply via email to