>> return rup->ru_utime.tv_sec*1000 + rup->ru_utime.tv_usec/1000
>> + rup->ru_stime.tv_sec*1000 + rup->ru_stime.tv_usec/1000;
>> I'd consider this improper, since it puts the operator where it
>> doesn't belong
> Why does not belong IYHO?
> The coding standards recommend that the expression follows below it
The examples being quite canonical IMHO.
> That is, we don't write:
> mode = inmode[j] == VOIDmode
> || GET_MODE_SIZE (outmode[j]) > GET_MODE_SIZE (inmode[j])
> ? outmode[j] : inmode[j];
Actually, some people do break the line before the || and indent it just
like that. That would show exactly the point of contention I've raised,
if it weren't for the '?' on the next line, that places operators of
different precedences at the same alignment.
Then they are doing it "wrong" -- or at least not following the coding
standards -- which is just fine too.
> Now, given that there is disagreement even here, I wonder if this is the
> proper forum to determine what the fix to the recommendation should be.
> Should I take it elsewhere, or is this the right forum to debate what
> the GNU general recommendation should be?
> This is probobly the right forum, I would suggest maybe adding
> addition examples, or maybe simply mentioning that the same rules
> apply for sizeof/return/...
Should I wait till we sort out the disagreement before proposing patches
for the standard, or should I propose a patch that states what I think
it was always meant to be?
A patch is I think always welcome, specially if it can clarify or put
less burden on the grey cells. As for the disagreement, _I_ don't see
it but that does not mean that it isn't there, I think the standard in
this regard is clear. But, things can always be made clearer if there
is such disagreement, not to mention that the standards are just a
recommendation -- one is free to apply them as a whole, parts or none.