On Mon, Sep 14, 2026 at 10:30:28PM +0000, SlowServers Admin wrote:
> Hi bugs@,
>
> I noticed -current changelog's message:
>
> commit 3eb032007ac46d07d258c2a3423bb68f3fea8821
> Author: dv <[email protected]>
> Date: Wed Sep 2 19:25:00 2026 +0000
>
> Require NRIP Save support for vmm(4) on AMD hosts.
>
> This feature gives a fast, reliable path to accurately advancing
> RIP when emulating certain instructions. Most AMD hardware from the
> past 15 years should have NRIP Save and nested paging support so
> this drops support for AMD hardware from roughly family 11h and
> older with some rare exceptions.
>
> Discussed multiple times in the past.
>
> ok mlarkin@
>
> This concerned me as my 4162 Opterons are 11h, if I'm not mistaken.
>
Sorry, supporting cpus without nrips for vmm/vmd was blocking progress
in several areas including SEV/SEV-ES and vmm/vmd SMP support.
According to google:
The AMD Family 11h processor family officially debuted on June 4, 2008
At some point we have to draw the line, and this is an 18 year old
CPU family. Your 4162 cpu was released June 2010.
> I loaded up the snapshot from the today, the 14th. The first install
> attempt crashed after extracting base -- I did not see the error. The
> second install attempt went fine.
>
Everything below has nothing to do with the nrips change. Looks like hardware
failure to me or some other transient snapshot error.
NOTE: nrips requirement ONLY affects vmm/vmd. So if you are not running
vmm/vmd on these machines, this commit won't affect you at all.
> I configured network, ran fw_update, and rebooted. After that boot,
> SSH didn't come up.
>
> Kernel relinking failed:
>
> Sep 14 22:11:03 slowservers0 reorder_kernel: failed -- see
> /usr/share/relink/kernel/GENERIC.MP/relink.log
>
> slowservers0# cat /usr/share/relink/kernel/GENERIC.MP/relink.log
> (SHA256) /bsd: OK
> LD="ld" sh makegap.sh 0xcccccccc gapdummy.o
> ld -T ld.script -X --warn-common -nopie --no-mmap-output-file -o newbsd
> ${SYSTEM_HEAD} vers.o ${OBJS}
> ld: error: drm_trace_points.o: unknown file type
> ld: error: dt_prov_kprobe.o: unknown file type
> ld: error: vesagtf.o: unknown file type
> ld: error: vers.o: unknown file type
> *** Error 1 in /usr/share/relink/kernel/GENERIC.MP (Makefile:2484
> 'newbsd': @echo ld -T ld.script -X --warn-common -nopie
> --no-mmap-output-f...)
>
> This sounds familiar, so maybe already a known issue.
>
> However, even ftp segfaults:
>
> slowservers0# ftp
> Segmentation fault (core dumped)
>
> But I'm able to start vmd and run vmctl show... So maybe my 4162 has
> NRIP Save after all? But very weird that ftp is segfaulting.
>
> Should ftp be segfaulting after the first reboot? I can share dmesg if
> helpful.
>
> I am seeing messages like this:
> ahci0: NCQ errored slot 28 is idle (00010000 active)
> ahci0: NCQ errored slot 7 is idle (00000079 active)
>
> Also, dd failed at 512MB?
>
> slowservers0# dd bs=1G if=/dev/zero count=24 of=disk
> dd: disk: Input/output error
> 6+0 records in
> 5+0 records out
> 5368709120 bytes transferred in 28.393 secs (189085659 bytes/sec)
>
> Yes, there's space. No weird mount options.
>
> Thanks!
>
> -Slow Servers
>