Hi,

I'd like to get a review of this small change to let the jdk8u/hotspot build system recognise another Microsoft compiler version:


8209359: [8u] hotspot needs to recognise cl.exe 19.13 to build with VS2017.
https://bugs.openjdk.java.net/browse/JDK-8209359

Diff below, just another if following the same pattern.

Thanks
Kevin


bash-4.2$ hg status
M make/windows/makefiles/compile.make
bash-4.2$ hg diff
diff -r b4ee249eb1c4 make/windows/makefiles/compile.make
--- a/make/windows/makefiles/compile.make       Tue Aug 07 11:55:44 2018 -0400 +++ b/make/windows/makefiles/compile.make       Fri Aug 10 05:26:34 2018 -0700
@@ -156,6 +156,9 @@
 !if "$(MSC_VER)" == "1912"
 COMPILER_NAME=VS2017
 !endif
+!if "$(MSC_VER)" == "1913"
+COMPILER_NAME=VS2017
+!endif
 !endif

 # By default, we do not want to use the debug version of the msvcrt.dll file


Reply via email to