2019/10/22 10:31:55 -0700, bob.vande...@oracle.com:
> In arguments.cpp, could you use a new JVMFlag to declare options that came 
> from this resource as RESOURCE?
> 
> - jint result = parse_each_vm_init_arg(vm_options_args, &patch_mod_javabase, 
> JVMFlag::INTERNAL);
> + jint result = parse_each_vm_init_arg(vm_options_args, &patch_mod_javabase, 
> JVMFlag::RESOURCE);
> 
> This will require some minor changes to jvmFlags.hpp
> 
>   34 struct JVMFlag {
>   35   enum Flags {
>   36     // latest value origin
>   37     DEFAULT          = 0,
>   38     COMMAND_LINE     = 1,
>   39     ENVIRON_VAR      = 2,
>   40     CONFIG_FILE      = 3,
>   41     MANAGEMENT       = 4,
>   42     ERGONOMIC        = 5,
>   43     ATTACH_ON_DEMAND = 6,
>   44     INTERNAL         = 7,
> 
> +  45     RESOURCE         = 8,
> 
>   46 
> 
> -  47      LAST_VALUE_ORIGIN = INTERNAL,
>  + 47     LAST_VALUE_ORIGIN = RESOURCE,

Yes, that’d make sense, in which case I’d also change JVMFlag::print_origin
to handle the RESOURCE case (which is easy).

Is “RESOURCE” the best name here?  Sounds awfully generic.  How about
“JIMAGE” or “JIMAGE_RESOURCE”?

- Mark

Reply via email to