On Tue, 15 Dec 2020 20:32:05 GMT, Magnus Ihse Bursie <i...@openjdk.org> wrote:

>> I thought it was a consistent and clear naming scheme. :-) But I guess to 
>> each their own...
>> 
>> Would `classloader-modules.conf`, `docs-modules.conf` and 
>> `build-modules.con` be better? Otherwise you'll need to come up with any 
>> better solutions yourself, since I'm starting to run out of ideas.
>
> As for `JRE_TOOL_MODULES`, I understand what you mean but it is at least kind 
> of a "sibling" to the others. After all, we use these sets of modules 
> together to form the set of modules for the JRE:
> 
> JRE_MODULES += $(filter $(ALL_MODULES), $(BOOT_MODULES) \
>     $(PLATFORM_MODULES) $(JRE_TOOL_MODULES))
> 
> So given that `BOOT_MODULES` and `PLATFORM_MODULE` has a role to play here as 
> well, I think it would be odd *not* to have `JRE_TOOL_MODULES` defined at the 
> same place.

`JRE_TOOL_MODULES` started with more than one modules in JDK 9:

JRE_TOOL_MODULES += \
    jdk.jdwp.agent \
    jdk.pack \
    jdk.scripting.nashorn.shell \
    #

Since only `jdk.jdwp.agent` one module is left for `JRE_TOOL_MODULES`, as you 
are refactoring this file, I suggest to get rid of `JRE_TOOL_MODULES` and 
explicitly name `jdk.jdwp.agent` in `JRE_MODULES`.

-------------

PR: https://git.openjdk.java.net/jdk/pull/1781

Reply via email to