On Mon, 7 Feb 2022 11:58:22 GMT, Andrew Haley <a...@openjdk.org> wrote:
>> enter_nested() ? >> enter_inner() ? > > Tell you what, first put a comment here that says when it should (and > therefore, should not) be used. Once it's clear exactly what this is for, > thinking of a name maight be easier. How about extending the existing enter() function: // Enter a new stack frame for the current method. // nested: Indicates a frame has already been entered (and not left) for the current method. void MacroAssembler::enter(bool nested=false) { if (nested) strip() protect() stp() mov() } This would add an additional bool check for every call of enter() - that's at code generation time, so probably not an issue. ------------- PR: https://git.openjdk.java.net/jdk/pull/6334