Am 16.02.2017 um 11:08 schrieb Vesta:
I managed successfully download the other MTD files via tftp, some of them larger in size 
than mtdblock6 "RootFileSystem". mtdblock6 size is near 4,3MB
The downloading is over the wan network, not via local net. In general, 
embedded CPU is weak and Busybox implementation with limited functions (no 
gzip, etc)
I've never been successful with using netcat on Busybox, only tftp worked. 
After running nc command it just stay forever, zero-size file been created on 
PC and it never got actual bytes. Netcat transfer can used in different ways, 
perhaps there is command variant that might work better in this particular 
case? Please specify netcat commamnd that can work in this situation, on 
transmit side and receive side.

Just tried on a live linux that has busybox on board, this would be your embedded device:

dd if=/dev/sr0 | nc -l -p 3456

On the receiver side (PC?) to retrieve the image:

nc 10.76.23.81 3456 > test.img

Yours,
Mattias


--
Mattias Schlenker - Freier IT-Fachredakteur und -autor
                             redakt...@mattiasschlenker.de
Mattias Schlenker - IT-Consulting, Softwareentwicklung
                            consult...@mattiasschlenker.de

Address__ August-Bebel-Str. 74 - D-04275 LEIPZIG - GERMANY
Phone: +49 341 39290767              Fax: +49 341 30393578
Mobile: +49 163  6953657  Another mobile: +49 159 03160327
VATIN_________________________________________ DE240998538

Fork me!____________________ https://github.com/mschlenker
Website.__________________ http://www.mattiasschlenker.de/
My books!___________ http://www.arduino-hausautomation.de/

_______________________________________________
busybox mailing list
busybox@busybox.net
http://lists.busybox.net/mailman/listinfo/busybox

Reply via email to