Hi,

According to the build instructions I try to build xerces-3.2.1 on
Windows 10 with VC14.
I type:

cmake -G "Visual Studio 14 2015 Win64"
-DCMAKE_INSTALL_PREFIX=I:\tools\x64 I:\tools\xerces-c-3.2.1\src


and I get:

I:\tools\xerces-c-3.2.1\build>cmake -G "Visual Studio 14 2015 Win64" -DCMAKE_INSTALL_PREFIX=I:\tools\x64 I:\tools\xerces-c-3.2.1\src
-- Selecting Windows SDK version  to target Windows 10.0.16299.
-- The C compiler identification is MSVC 19.0.24215.1
-- The CXX compiler identification is MSVC 19.0.24215.1
-- Check for working C compiler: C:/Program Files (x86)/Microsoft Visual Studio 14.0/VC/bin/x86_amd64/cl.exe -- Check for working C compiler: C:/Program Files (x86)/Microsoft Visual Studio 14.0/VC/bin/x86_amd64/cl.exe -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: C:/Program Files (x86)/Microsoft Visual Studio 14.0/VC/bin/x86_amd64/cl.exe -- Check for working CXX compiler: C:/Program Files (x86)/Microsoft Visual Studio 14.0/VC/bin/x86_amd64/cl.exe -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
CMake Error at CMakeLists.txt:1291 (install):
  install TARGETS given no ARCHIVE DESTINATION for static library target
  "xerces-c".


CMake Error at C:/Program Files/CMake/share/cmake-3.10/Modules/WriteBasicConfigVersionFile.cmake:40 (message):
  No VERSION specified for WRITE_BASIC_CONFIG_VERSION_FILE()
Call Stack (most recent call first):
C:/Program Files/CMake/share/cmake-3.10/Modules/CMakePackageConfigHelpers.cmake:207 (write_basic_config_version_file)
  CMakeLists.txt:1308 (write_basic_package_version_file)


CMake Warning (dev) in CMakeLists.txt:
  No cmake_minimum_required command is present.  A line of code such as

    cmake_minimum_required(VERSION 3.10)

should be added at the top of the file. The version specified may be lower
  if you wish to support older CMake versions for this project.  For more
  information run "cmake --help-policy CMP0000".
This warning is for project developers.  Use -Wno-dev to suppress it.

-- Configuring incomplete, errors occurred!
See also "I:/tools/xerces-c-3.2.1/build/CMakeFiles/CMakeOutput.log".


Any help?
Thomas

---------------------------------------------------------------------
To unsubscribe, e-mail: c-dev-unsubscr...@xerces.apache.org
For additional commands, e-mail: c-dev-h...@xerces.apache.org

Reply via email to