How about FetchWhen.Immediate and FetchWhen.OnInvoke ? It would also be more appropriate to rename the existing FetchEnum to FetchHow, which would of course break existing code.
2009/5/7 Lee Henson <[email protected]> > Er, kind of conflicts with: > > Fetch=FetchEnum.Join > > no? > > 2009/5/7 Roelof Blom <[email protected]> > > Yeah, I don't like it either. How about Fetch.Immediate and Fetch.Proxy >> (the terminology comes from paragraph 16.1 NH Reference >> documentation<http://knol.google.com/k/fabio-maulo/nhibernate-chapter-16/1nr4enxv3dpeq/19#> >> ) >> >> -- Roelof. >> >> 2009/5/6 Krzysztof Koźmic <[email protected]> >> >> But please, rename the LazyEnum type. >>> >>> Markus Zywitza pisze: >>> >>> Will still go into Alpha 1. Thanks for the contribution, especially >>> for one with tests ;-) >>> >>> -Markus >>> >>> 2009/5/6 Lee Henson <[email protected]> <[email protected]>: >>> >>> >>> I've uploaded a patch with the following ticket on donjon: >>> http://support.castleproject.org/projects/AR/issues/view/AR-ISSUE-253 >>> >>> which adds: >>> >>> [BelongsTo .... Lazy=LazyEnum.Proxy] >>> [BelongsTo .... Lazy=LazyEnum.False] >>> >>> Markus, I'm not sure what your release plans are at the moment so I've >>> left it as a patch rather than just committing it outright. >>> >>> >>> >>> >>> >>> >> >> >> > > > > --~--~---------~--~----~------------~-------~--~----~ You received this message because you are subscribed to the Google Groups "Castle Project Development List" group. To post to this group, send email to [email protected] To unsubscribe from this group, send email to [email protected] For more options, visit this group at http://groups.google.com/group/castle-project-devel?hl=en -~----------~----~----~----~------~----~------~--~---
