My vote is for the function call in CFSET/CFSCRIPT.  if you need named
arguments (rather than positional), just use an argumentCollection.
It's minutely less readable than CFINVOKE/CFINVOKEARGUMENT (because
the arguments are defined before the function name is listed), but
I've never had that be a problem, and it's a heck of a lot less
typing.  Of course, I avoid anything but positional parameters when I
can, but that's a personal preference, not for efficiency or anything.

cheers,
barneyb

On Fri, 30 Jul 2004 12:24:12 -0400, Michael Dinowitz
<[EMAIL PROTECTED]> wrote:
> True. I didn't think of that. Now the original question is, what's faster/better for internal method calls.
> 1. <CFINVOKE method...>
> 2. <CFINVOKE component="#this#" method...>
> 3. function call
>
> I prefer one of the first 2 as the CFINVOKE is cleaner, but which of those two are better. If both are the same, then it's an issue of style.
>
> >You could also do
> >
> ><cfinvoke component="#this#" method="..." ...>
> >
> >Which I think is easier to understand than a cfinvoke without a component
> >attribute (didn't know that worked, but still prefer to specify component).
> >
> >Sam
> >
> >
> >
> >----------------------------------------
> >Blog http://www.rewindlife.com
> >TeamMM http://www.macromedia.com/go/team
> >
[Todays Threads] [This Message] [Subscription] [Fast Unsubscribe] [User Settings] [Donations and Support]

Reply via email to