baloghadamsoftware marked an inline comment as done.
baloghadamsoftware added inline comments.


================
Comment at: clang/lib/StaticAnalyzer/Checkers/ContainerModeling.cpp:780
 
+  if (AggressiveEraseModeling) {
+    if (const auto *CData = getContainerData(State, ContReg)) {
----------------
martong wrote:
> This seems to be very similar to the hunk we have in `handleErase`, so this 
> suggests some unnecessary code duplication. I presume we could create a 
> function which is called from both callers.
Yes, I was thinking about that as well. Many parameters have to be passed so it 
will be not so much shorter.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D77150/new/

https://reviews.llvm.org/D77150



_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to