sdesmalen added a comment.

Please rename `debug-declare-no-warnings-on-scalable-vectors.ll` to something 
different, because these 'warnings' are only temporary and will be replaced by 
errors in the future. Having 'no warnings' in the name of the test name seems 
wrong from that perspective.

In D91806#2413692 <https://reviews.llvm.org/D91806#2413692>, @fpetrogalli wrote:

>> This patch needs to be retitled to what this is actually doing: changing the 
>> getTypeAllocationSizeInBits and getFragmentSizeInBits to return a TypeSize 
>> instead of unsigned.
>
> Given that the only change resulting from this patch is removing the warning, 
> I think it makes sense to keep the summary of the patch as it is.

Given that the generated warnings are temporary and only a side-effect of the 
implicit conversion 'hack', and thus not a feature or design choice, I still 
think the patch needs to be retitled to better phrase what it does, i.e. change 
getTypeAllocationSizeInBits to return TypeSize instead of unsigned.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D91806/new/

https://reviews.llvm.org/D91806

_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to