dcoughlin added a comment.
I think this is much clearer! That said, now that I look at it with
'POSTCONDITION' alone I don't think it is clear that the provided value
describes the return value. What do you think about renaming it 'RETURN_VALUE'?
Or adding back the RET_VAL I asked you about removing before? :-)
Also: do you think CONDITION_KIND is needed? in PRECONDITION? Or can the bare
kind be used like in POSTCONDITION?
cfe-commits mailing list