NoQ added a comment.

In, @dcoughlin wrote:

> That said, now that I look at it with 'POSTCONDITION' alone I don't think it 
> is clear that the provided value describes the return value. What do you 
> think about renaming it 'RETURN_VALUE'? Or adding back the RET_VAL I asked 
> you about removing before? :-)

Hmm, what about

    ARGUMENT_VALUE(0, WithinRange)
      RANGE('0', '9')
      RANGE('A', 'Z')
      RANGE('a', 'z')


Something i don't like here is that the word "value" is overloaded. Maybe 
rename the inner `VALUE` back to `POINT`?

In, @dcoughlin wrote:

> Also: do you think CONDITION_KIND is needed? in PRECONDITION? Or can the bare 
> kind be used like in POSTCONDITION?

I agree that it's ok to use the bare kind, because it's quite self-explanatory.

cfe-commits mailing list

Reply via email to