Good afternoon,

Operating system: Ubuntu 18.04.1 LTS
Hardware platform: x86_64 (AMD A8-7600)
C Compiler: gcc 7.3.0
Installation works?: yes
Tests work?: yes
Installation of eggs works?: fails to install 'format'

claude@GuloGulo:~/Programming/scheme$ chicken-install format
Server error:
Error: [Server] no such extension or version
Server error:
Error: [Server] no such extension or version
Error: extension or version not found: "format"

I must be missing something. Could the previous installation of Chicken
4,.13.0 be interfering?

Building a simple time stamp program fails.
csc timestamp.scm
./timestamp > prologue.scm
Error: unbound variable: command-line-arguments
    Call history:
    timestamp.scm:70: command-line-arguments          <--
That should be in process-context which is included. Add this and try again.
(declare (uses process-context))
Fails again.
sc timestamp.scm
timestamp.o: In function `f_154':
timestamp.c:(.text+0x612): undefined reference to
collect2: error: ld returned 1 exit status

Removing the offending call and the declaration reveals another issue: it
cannot find seconds->local-time. So, I added this.
(declare (uses time))
Does not work.
timestamp.c:(.text+0x5f3): undefined reference to `C_time_toplevel'
Then I added this.
(declare (uses time posix))
Same error.

I have not worked with Chicken is several months. Am I missing something

Thank you.

Claude Marinier
Chicken-users mailing list

Reply via email to