Hi Alexander,

It should be possible to add new shares as well as set share ACLs via MMC. From your description, your system seems to be in a bad state.
One thing to try out would be to refresh/restart SMB server service.

Additionally, if you could provide us with the following information, that would help us better analyze the problem.

1). Network capture (wireshark or snoop) of the operations you are trying to perform.

2). Output of the cifs-gendiag script. This script can be downloaded from the following site.


3) Output of the msrpc.d script.


Best Regards,

Hi all,

I’m just getting started with OpenSolaris to try and see if we can utilize it as a NAS CIFS server (combination with X4540 seems very promising). Most of the setup was easy especially when coming from a UNIX/Linux background. However we have a number of Windows administrators so using the Windows MMC for administering the CIFS shares would be a great pro.

Using a Windows (Windows 7) client I can connect to the OpenSolaris machine (which is joined to an Active Directory domain), using the MMC. I can browse the logs, check the services and browse shares, sessions and open files. I can set security permissions on the shares. However I run into issues when trying to set share permissions. I can see the permissions, but changing them from the MMC is not possible. Changes are immediately reverted to their original values. I am able to set correct ACLs on the share from OpenSolaris itself using the CLI (using the .zfs/shares directory), but it’s a bit of a pain to use it that way to be honest. Is this a known issue with b134?

Also, I’ve read in a number of SUN presentations that adding new shares from the MMC should work, however I cannot get it to work. Every folder path I’ve tried is denied. For me this really isn’t a big issue, but it would be nice to know the current status of the MMC implementation. J


Best regards,

  Alexander Brinkman.

cifs-discuss mailing list

Reply via email to