Thanks for the tips. I’ve rebooted the machine. Situation has not improved.


>From Windows explorer, going to the file share and changing file permissions 
>works, however any action involving shares and the MMC results in “Changes 
>cannot be saved. The storage control blocks were destroyed.” error on the 
>client. Both for changes to the share permissions as the security permissions.


I will try to get a wireshark capture and the logs.


Best regards,



From: Keyur Desai [] 
Sent: dinsdag 6 april 2010 17:18
To: Brinkman, Alexander
Subject: Re: [cifs-discuss] CIFS management from Windows MMC


Hi Alexander,

It should be possible to add new shares as well as set share ACLs via MMC. From 
your description, your system seems to be in a bad state.
One thing to try out would be to refresh/restart SMB server service. 

Additionally, if you could provide us with the following information, that 
would help us better analyze the problem.

1). Network capture (wireshark or snoop) of the operations you are trying to 

2). Output of the cifs-gendiag script. This script can be downloaded from the 
following site.

3) Output of the msrpc.d script.

Best Regards,

Hi all,


I’m just getting started with OpenSolaris to try and see if we can utilize it 
as a NAS CIFS server (combination with X4540 seems very promising). Most of the 
setup was easy especially when coming from a UNIX/Linux background. However we 
have a number of Windows administrators so using the Windows MMC for 
administering the CIFS shares would be a great pro.


Using a Windows (Windows 7) client I can connect to the OpenSolaris machine 
(which is joined to an Active Directory domain), using the MMC. I can browse 
the logs, check the services and browse shares, sessions and open files. I can 
set security permissions on the shares. However I run into issues when trying 
to set share permissions. I can see the permissions, but changing them from the 
MMC is not possible. Changes are immediately reverted to their original values. 
I am able to set correct ACLs on the share from OpenSolaris itself using the 
CLI (using the .zfs/shares directory), but it’s a bit of a pain to use it that 
way to be honest. Is this a known issue with b134?


Also, I’ve read in a number of SUN presentations that adding new shares from 
the MMC should work, however I cannot get it to work. Every folder path I’ve 
tried is denied. For me this really isn’t a big issue, but it would be nice to 
know the current status of the MMC implementation. J




        Best regards,

          Alexander Brinkman.


ing. Alexander Brinkman
Co-ordinator ICT
MSuG MARIN Support Group
T +31 317 49 34 99

2, Haagsteeg, P.O. Box 28, 6700 AA Wageningen, The Netherlands
T +31 317 49 39 11, F +31 317 49 32 50, I
 SAFETUG, a unique € 3 million joint industry project concludes 

This e-mail may be confidential, privileged and/or protected by copyright. If 
you are not the intended recipient, you should return it to the sender 
immediately and delete your copy from your system.



cifs-discuss mailing list

Reply via email to