I have a class where I would like to have a method name like:

-(void)setMaximumOperations:(NSInteger)operations
{
  [[self operationQueue] setMaxConcurrentOperationCount:operations];

   ... Do other stuff ...
}

Is this a bad idea? There is no property called "maximumOperations" in my
class but using a "set" method name in this way may imply there is, although
the compiler likely doesn't care.

How is the best way to name something like this?




_______________________________________________

Cocoa-dev mailing list (Cocoa-dev@lists.apple.com)

Please do not post admin requests or moderator comments to the list.
Contact the moderators at cocoa-dev-admins(at)lists.apple.com

Help/Unsubscribe/Update your Subscription:
https://lists.apple.com/mailman/options/cocoa-dev/archive%40mail-archive.com

This email sent to arch...@mail-archive.com

Reply via email to