> Le 2 août 2016 à 07:11, Trygve Inda <cocoa...@xericdesign.com> a écrit :
> 
> I have a class where I would like to have a method name like:
> 
> -(void)setMaximumOperations:(NSInteger)operations
> {
>  [[self operationQueue] setMaxConcurrentOperationCount:operations];
> 
>   ... Do other stuff ...
> }
> 
> Is this a bad idea? There is no property called "maximumOperations" in my
> class but using a "set" method name in this way may imply there is, although
> the compiler likely doesn't care.
> 
> How is the best way to name something like this?

Actually, there is no difference between a property and a pair of getter/setter 
methods.  Here you have defined a write-only property, and since you have this 
method, you could write: 

   o.maximumOperations=42;

as well as:

   [o setMaximumOperations:42]

The same code is generated in both cases. 

If you added a method -(NSInteger)maximumOperations then you'd have a 
read-write property. 

You can call it a derived property, since it is not implemented directly as a 
slot of your instances. 



-- 
__Pascal Bourguignon__

_______________________________________________

Cocoa-dev mailing list (Cocoa-dev@lists.apple.com)

Please do not post admin requests or moderator comments to the list.
Contact the moderators at cocoa-dev-admins(at)lists.apple.com

Help/Unsubscribe/Update your Subscription:
https://lists.apple.com/mailman/options/cocoa-dev/archive%40mail-archive.com

This email sent to arch...@mail-archive.com

Reply via email to