This is an automated email from the ASF dual-hosted git repository.
pearl11594 pushed a change to branch nsx-refactor-update-offering
in repository https://gitbox.apache.org/repos/asf/cloudstack.git
from 0e3fd1ff533 update nsx_mode parameter
add 69ded800e99 modify NSX resource naming convention (#8095)
add 386ba2f3af0 Merge branch 'nsx-integration' of
https://github.com/apache/cloudstack into nsx-refactor-update-offering
No new revisions were added by this update.
Summary of changes:
.../java/com/cloud/network/guru/NetworkGuru.java | 2 ++
.../com/cloud/vm/VirtualMachineManagerImpl.java | 18 ++++++++++---
.../engine/orchestration/NetworkOrchestrator.java | 1 +
.../cloud/vm/VirtualMachineManagerImplTest.java | 16 +++++++-----
.../network/contrail/management/ContrailGuru.java | 5 ++++
.../agent/api/CreateNsxDhcpRelayConfigCommand.java | 19 +++++++++++---
.../agent/api/CreateNsxSegmentCommand.java | 19 +++++++++++---
.../agent/api/CreateNsxTier1GatewayCommand.java | 10 ++++++--
.../agent/api/DeleteNsxSegmentCommand.java | 18 +++++++++++--
.../agent/api/DeleteNsxTier1GatewayCommand.java | 10 ++++++--
.../apache/cloudstack/agent/api/NsxCommand.java | 30 +++++++++++-----------
.../apache/cloudstack/resource/NsxResource.java | 28 ++++++++++----------
.../apache/cloudstack/service/NsxApiClient.java | 10 ++++----
.../org/apache/cloudstack/service/NsxElement.java | 8 +++---
.../cloudstack/service/NsxGuestNetworkGuru.java | 10 ++++++--
.../apache/cloudstack/service/NsxServiceImpl.java | 13 +++++-----
.../cloudstack/utils/NsxControllerUtils.java | 25 +++++++++---------
.../org/apache/cloudstack/utils/NsxHelper.java | 8 +++---
.../cloudstack/resource/NsxResourceTest.java | 14 +++++-----
.../apache/cloudstack/service/NsxElementTest.java | 7 ++---
.../service/NsxGuestNetworkGuruTest.java | 21 +++++++++++----
.../cloudstack/service/NsxServiceImplTest.java | 6 ++---
.../com/cloud/hypervisor/HypervisorGuruBase.java | 20 +++++++++++----
.../com/cloud/network/guru/ControlNetworkGuru.java | 5 ++++
.../com/cloud/network/guru/DirectNetworkGuru.java | 5 ++++
.../com/cloud/network/guru/GuestNetworkGuru.java | 5 ++++
.../cloud/network/guru/PodBasedNetworkGuru.java | 5 ++++
.../com/cloud/network/guru/PrivateNetworkGuru.java | 5 ++++
.../com/cloud/network/guru/PublicNetworkGuru.java | 5 ++++
.../vmware/mo/HypervisorHostHelperTest.java | 2 +-
30 files changed, 241 insertions(+), 109 deletions(-)