rangareddy commented on issue #17387:
URL: https://github.com/apache/hudi/issues/17387#issuecomment-5351242780

   This issue was reviewed as part of the JIRA-migrated backlog triage 
(HUDI-9112).
   
   **Findings: not done. One thing to correct first, so nobody searches in 
vain.**
   
   The method named in this ticket, `getTableAvroSchemaFromTimelineWithCache`, 
no longer exists under that name. The Avro-to-`HoodieSchema` migration (#17599, 
`Remove HoodieAvroUtils from hudi-client-common`, and #17659, schema phase 18) 
renamed it to **`getTableSchemaFromTimelineWithCache`**. It is at:
   
   - 
`hudi-client/hudi-client-common/src/main/java/org/apache/hudi/client/transaction/ConcurrentSchemaEvolutionTableSchemaGetter.java:121`
 (single-arg convenience form)
   - `:126` (the two-arg implementation that holds the logic)
   
   The complaint still stands. That implementation carries conditionals at 
`:133`, `:138`, `:140`, `:147`, `:150`, `:155` and `:158`, with three more at 
`:182`, `:189` and `:200` in the helper below it - roughly 90 lines of 
interleaved cache lookup, target-instant resolution, and 
fallback-to-last-valid-commit logic. The class has been touched since (#19388 
fixed an NPE in schema conflict resolution, #17524 applied lombok) but neither 
was a simplification.
   
   Suggest updating the ticket title/description to the current method name so 
it stays findable.
   
   Keeping this open.
   


-- 
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

To unsubscribe, e-mail: [email protected]

For queries about this service, please contact Infrastructure at:
[email protected]

Reply via email to