Kai Zheng commented on HADOOP-13609:

Thanks Genmao working on this. Looking at the change, some comments:
1. Could we remove the {{Temporary}} from the provider name? Maybe the related 
codes can be consolidated together so to make it look solid?
2. {{static public}} could be: {{public static}}
3. {{getAliyunAccessKeys}} maybe {{getValueWithKey}}

Please rebase and update the patch. Thanks.

> Refine credential provider related codes for AliyunOss integration
> ------------------------------------------------------------------
>                 Key: HADOOP-13609
>                 URL: https://issues.apache.org/jira/browse/HADOOP-13609
>             Project: Hadoop Common
>          Issue Type: Sub-task
>          Components: fs
>    Affects Versions: HADOOP-12756
>            Reporter: Kai Zheng
>            Assignee: Genmao Yu
>             Fix For: HADOOP-12756
>         Attachments: HADOOP-13609-HADOOP-12756.001.patch
> looking at the AliyunOss integration codes, some findings:
> 1. {{TemporaryAliyunCredentialsProvider}} could be better named;
> 2. TemporaryAliyunCredentialsProvider shared many codes with 
> {{AliyunOSSUtils#getCredentialsProvider}}, and the dup can be resolved;
> 3. {{AliyunOSSUtils#getPassword}} is rather confusing, as used to get other 
> things than password.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: common-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-issues-h...@hadoop.apache.org

Reply via email to