[ 
https://issues.apache.org/jira/browse/HADOOP-13609?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15500439#comment-15500439
 ] 

Genmao Yu edited comment on HADOOP-13609 at 9/18/16 7:46 AM:
-------------------------------------------------------------

1. We can rename "TemporaryAliyunCredentialsProvider" to 
"AliyunSessionCredentialsProvider". One of benefits is to provide an example of 
implementation of "CredentialsProvider". And you opinion?
2. +1. Typo error
3. +1.


was (Author: unclegen):
1. We can rename "TemporaryAliyunCredentialsProvider" to 
"AliyunSessionCredentialsProvider". One of benefits is to provide an example of 
implementation of "CredentialsProvider". 
2. +1. Typo error
3. +1.

> Refine credential provider related codes for AliyunOss integration
> ------------------------------------------------------------------
>
>                 Key: HADOOP-13609
>                 URL: https://issues.apache.org/jira/browse/HADOOP-13609
>             Project: Hadoop Common
>          Issue Type: Sub-task
>          Components: fs
>    Affects Versions: HADOOP-12756
>            Reporter: Kai Zheng
>            Assignee: Genmao Yu
>             Fix For: HADOOP-12756
>
>         Attachments: HADOOP-13609-HADOOP-12756.001.patch
>
>
> looking at the AliyunOss integration codes, some findings:
> 1. {{TemporaryAliyunCredentialsProvider}} could be better named;
> 2. TemporaryAliyunCredentialsProvider shared many codes with 
> {{AliyunOSSUtils#getCredentialsProvider}}, and the dup can be resolved;
> 3. {{AliyunOSSUtils#getPassword}} is rather confusing, as used to get other 
> things than password.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-issues-h...@hadoop.apache.org

Reply via email to