[ 
https://issues.apache.org/jira/browse/HADOOP-15954?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16753623#comment-16753623
 ] 

Thomas Marquardt commented on HADOOP-15954:
-------------------------------------------

*CustomIdentityTransformer.java*:

L94 - replace groupName with userName in the comment

*DefaultSPIdentityTransformer.java*:

L49: We can remove SP from the name since i) people will not know this is an 
abbreviation for service principal and ii) this class does more. 
 I recommend naming it DefaultIdentityTransformer.

L84-92: There is code in AzureBlobFileSystem.initiailize that sets user and 
principalUserGroup, and also changes that behavior based on config settings. 
 It seems we should pass the values for user and group into 
DefaultIdentityTransformer.initialize.

L107-114: Should the short name conversion be done outside the else?

L117: We should avoid the extra FileStatus allocation, especially since this is 
used for list operations. These allocations can add up.
 Since the interface is really about the ability to transform identities, I am 
wondering why we allow the interface to replace the entire FileStatus? 
 Looking at AzureBlobFileSystemStore.getFileStatus and listFileStatus, it 
appears we could replace the owner and owning group before we create the file
 status, which would avoid extra allocations, especially for list.

L125-129: If for some reason this function is not removed based on the comment 
above...note that replacement can be done in place using the current array, and 
 thereby avoid a potentially large allocation. Just change the signature to 
void transformListStatus(FileStatus[] entries).

L157: Similar to comment L117 above, why not convert the owner and owning group 
inside AzureBlobFileSystemStore.getAclStatus before the AclStatus is created?  
This would avoid the extra AclStatus allocation and builder.

> ABFS: Enable owner and group conversion for MSI and login user using OAuth
> --------------------------------------------------------------------------
>
>                 Key: HADOOP-15954
>                 URL: https://issues.apache.org/jira/browse/HADOOP-15954
>             Project: Hadoop Common
>          Issue Type: Sub-task
>          Components: fs/azure
>    Affects Versions: 3.2.0
>            Reporter: junhua gu
>            Assignee: Da Zhou
>            Priority: Major
>         Attachments: HADOOP-15954-001.patch, HADOOP-15954-002.patch, 
> HADOOP-15954-003.patch, HADOOP-15954-004.patch, HADOOP-15954-005.patch, 
> HADOOP-15954-006.patch, HADOOP-15954-007.patch, HADOOP-15954-008.patch, 
> HADOOP-15954-009.patch, HADOOP-15954-010.patch, HADOOP-15954-011.patch, 
> HADOOP-15954-012.patch
>
>
> Add support for overwriting owner and group in set/get operations to be the 
> service principal id when OAuth is used. Add support for upn short name 
> format.
>  
> Add Standard Transformer for SharedKey / Service 
> Add interface provides an extensible model for customizing the acquisition of 
> Identity Transformer.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-issues-h...@hadoop.apache.org

Reply via email to