[ 
https://issues.apache.org/jira/browse/HADOOP-15954?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16754212#comment-16754212
 ] 

Da Zhou commented on HADOOP-15954:
----------------------------------

Thanks for pointing out!  Yes I realized some issues mentioned above so I was 
working on the improvement.
 [~ste...@apache.org]
 *CustomIdentityTransformer*: Sure, I will add filesystem URI and close().
 *transformListStatus(FileStatus[])*: I plan to remove this from interface 
because it causes extra allocation, and this could be avoided by just declaring 
sth like "*void transformUserAndGroupForWriteOperation(String[]userGroup))*" 
and "*void transformUserAndGroupForReadOperation(String[]userGroup))*", so the 
updated owner and group can be used to create FileStatus/AclStatus, as 
mentioned by [~tmarquardt] for L117.
Will update the logic expression to improve readability.
 *ITestAbfsIdentityTransformer*: will do the refactoring.

[~tmarquardt] 
DefaultSPIdentityTransformer.java:
L84-92: Yes the use/group is inconsistent when exception happens when parsing 
userGroupInfo in AzureBlobFileSystem and DefaultIdentityTransformer.
L107-114: once the owner meet the first if condition and get transformed to 
localUser(which is already a shortUserName), then checking  
shouldUseShortUserName() will be redundant, that is the reason it is put in the 
else. 
L117, L125-129, L157: these will be resolved. "void 
transformListStatus(FileStatus[] entries)" makes sense.

> ABFS: Enable owner and group conversion for MSI and login user using OAuth
> --------------------------------------------------------------------------
>
>                 Key: HADOOP-15954
>                 URL: https://issues.apache.org/jira/browse/HADOOP-15954
>             Project: Hadoop Common
>          Issue Type: Sub-task
>          Components: fs/azure
>    Affects Versions: 3.2.0
>            Reporter: junhua gu
>            Assignee: Da Zhou
>            Priority: Major
>         Attachments: HADOOP-15954-001.patch, HADOOP-15954-002.patch, 
> HADOOP-15954-003.patch, HADOOP-15954-004.patch, HADOOP-15954-005.patch, 
> HADOOP-15954-006.patch, HADOOP-15954-007.patch, HADOOP-15954-008.patch, 
> HADOOP-15954-009.patch, HADOOP-15954-010.patch, HADOOP-15954-011.patch, 
> HADOOP-15954-012.patch
>
>
> Add support for overwriting owner and group in set/get operations to be the 
> service principal id when OAuth is used. Add support for upn short name 
> format.
>  
> Add Standard Transformer for SharedKey / Service 
> Add interface provides an extensible model for customizing the acquisition of 
> Identity Transformer.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: common-issues-h...@hadoop.apache.org

Reply via email to