[
https://issues.apache.org/jira/browse/HADOOP-10793?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14055084#comment-14055084
]
Larry McCay commented on HADOOP-10793:
--------------------------------------
Hi [~yoderme] - the double dash style was intentionally used for this shell and
is aligned with the CredentialShell for the Credential Provider API. I would
suggest adding single dash arguments for shortened names if you would rather
that style single dashes. I don't believe that we should be limited to the
styles used in previous tooling when another is preferred and popular. In
addition, what is the value of replacing the command line parsing mechanism?
This was modeled after an existing tool and serves the purpose well - afaict?
> Key Shell args use double dash style
> ------------------------------------
>
> Key: HADOOP-10793
> URL: https://issues.apache.org/jira/browse/HADOOP-10793
> Project: Hadoop Common
> Issue Type: Improvement
> Components: security
> Affects Versions: 3.0.0
> Reporter: Mike Yoder
>
> Follow-on from HADOOP-10736 as per [~andrew.wang] - the key shell uses the
> gnu double dash style for command line args, while other command line
> programs use a single dash. Consider changing this, and consider another
> argument parsing scheme, like the CommandLine class.
--
This message was sent by Atlassian JIRA
(v6.2#6252)