> I personally like the Lists, Sets, Collections, etc naming,
> too.  We could put pass-through methods to
> java.util.Collections on the commons.Collections class. 
> That way we can have our cake and eat it too.  

I definitely agree that code like this is nicer:

  Bag bag = Bags.synchronizedBag(Bags.predicatedBag(new HashBag(), pred));

...I mean, how cool is it that all that actually fits on one line?

However, I don't think your idea of using pass-through methods 
can work.  The Collections project is committed to remaining 
JDK1.2 compatible, and methods have been added to java.util.Collections
in JDK1.3, 1.4.  

I'd love it if we could just subclass java.util.Collections,
inheriting all of its static methods and then supplying our own...
But alas, its constructor is private.

And anyway, since we already have the Utils convention, we're 
kind of stuck with it...

-Paul


--
To unsubscribe, e-mail:   <mailto:[EMAIL PROTECTED]>
For additional commands, e-mail: <mailto:[EMAIL PROTECTED]>

Reply via email to