Personally I wouldn't use INDEX_NOT_FOUND, as -1 is so well known. Stephen
----- Original Message ----- From: "Gary Gregory" <[EMAIL PROTECTED]> To: "'Jakarta Commons Developers List'" <[EMAIL PROTECTED]> Sent: Thursday, September 04, 2003 7:22 PM Subject: [lang] StringUtils.ordinalIndexOf() and INDEX_NOT_FOUND > Hello All, > > I've added StringUtils.ordinalIndexOf() and introduced a new constant > StringUtils.INDEX_NOT_FOUND = -1. Currently, only ordinalIndexOf uses this > constant. > > I would like to get a fell if folks think that replacing (where > appropriate), the -1 magic number usage in StringUtils with this constant is > a good idea or refactoring gone wild. > > Thanks, > Gary > --------------------------------------------------------------------- To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, e-mail: [EMAIL PROTECTED]
