Steve Cohen wrote:
I must say, though that the name of your function is as ugly a method name as any I've ever seen.
I know it, i hate it too, but ...
For sure, i can drop the word FTP as it is redundant (counted to how often the word FTP appears in the FQCN of the builder-class)
I dont like "setParserKey()" as this might look like it is an argument to the parser class and not to its factory. Even if this should not concern VFS - this is how it is.
Next thing is "setParserFactoryKey()", but then - which parser factory is meant here ?
What do you think about renaming *) setFTPFileEntryParserFactoryKey() to setEntryParserFactoryKey() *) setFTPFileEntryParserFactory() to setEntryParserFactory() ?
-- Mario
--------------------------------------------------------------------- To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, e-mail: [EMAIL PROTECTED]
