Well, I don't really agree with you about your reasons not to like 
setParserKey().  It's a key that ultimately gets translated into a parser.  
The name doesn't have to imply ownership, and I'm still not sure what the 
problem would be even if a VFS user thought it did.   If the user cares about 
the underlying object model, he's got the source.   But it's up to you.

Still, I'm all for "shorter is better" and therefore I am in favor of the two 
renamings you propose as improvements over the current names.



Steve

On Monday 20 September 2004 1:11 am, Mario Ivankovits wrote:
> Steve Cohen wrote:
> >I must say, though that the name of your function is as ugly a method name
> > as any I've ever seen.
>
> I know it, i hate it too, but ...
>
> For sure, i can drop the word FTP as it is redundant (counted to how
> often the word FTP appears in the FQCN of the builder-class)
>
> I dont like "setParserKey()" as this might look like it is an argument
> to the parser class and not to its factory. Even if this should not
> concern VFS - this is how it is.
>
> Next thing is "setParserFactoryKey()", but then - which parser factory
> is meant here ?
>
> What do you think about renaming
> *) setFTPFileEntryParserFactoryKey() to setEntryParserFactoryKey()
> *) setFTPFileEntryParserFactory() to setEntryParserFactory()
> ?
>
> --
> Mario
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [EMAIL PROTECTED]
> For additional commands, e-mail: [EMAIL PROTECTED]


---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to