Am Freitag, den 26.09.2008, 16:54 +0000 schrieb Matthias Camenzind:
> Hi,
> I can't connect to the internet from my freerunner. Usb network and ssh is 
> working. Wifi and bluetooth is not working. I would like to install debian, 
> because i think on debian wifi should work.
> Freerunner: Om2007.2 (over terminal i can install ipk-packages, but 
> dependences are to deep to load every file manually)
> Freerunner SD(2GB): Om2008 (wifi finds an unsecured net, but is not able to 
> connect)
> Laptop: Ubuntu 8.04 (I tried to install a dhcp router but didn't work. I 
> tried also forwadings over iptables but didn't work)
> Has someone some ideas wich could help me?

I act also very long time with my iptables till it works fine.

I need to run following commands at my server/notebook:
> iptables -I RH-Firewall-1-INPUT -s 192.168.0.202 -j ACCEPT

> iptables -t nat -A POSTROUTING -j MASQUERADE -s 192.168.0.0/24

> iptables -t nat -A PREROUTING -p tcp -s 192.168.0.202 -d 192.168.0.200
--dport 53 -j DNAT --to-destination 212.6.108.140

> iptables -t nat -A PREROUTING -p udp -s 192.168.0.202 -d 192.168.0.200
--dport 53 -j DNAT --to-destination 212.6.108.140

> sysctl -w net.ipv4.ip_forward=1

> iptables-save

...and on my FR I set the nameserver to my common one:
> echo nameserver 212.6.108.140>/etc/resolv.conf

the sysctl command is most important, otherwise, the forwarding won't
work.
That's all.
-- 

mfg/br, christian

Flurstraße 14
29640 Schneverdingen
Germany

E-Mail: [EMAIL PROTECTED]
Telefon: +49 5193 97 14 95
Mobile:  +49 171 357 59 57
http://wesselch.homelinux.org

Attachment: signature.asc
Description: Dies ist ein digital signierter Nachrichtenteil

_______________________________________________
Openmoko community mailing list
community@lists.openmoko.org
http://lists.openmoko.org/mailman/listinfo/community

Reply via email to